It is currently Sat Nov 25, 2017 12:53 am


Post a new topicPost a reply Page 1 of 1   [ 7 posts ]
Author Message
 Post subject: Cloning Windows Xp Boot Drive (hard drive upgrade)
PostPosted: Fri Dec 29, 2006 10:33 am 
Sr. Member
Sr. Member
User avatar

Joined: Mon Sep 05, 2005 1:32 am
Posts: 352
I'm trying to upgrade the boot disk in my second computer to a spare SATA drive.

I've used Norton Ghost or Partition Magic to clone the disk, after which I disconnect the old drive (ATA) and reboot with the new. I've done this a few times in the past without any problems.

When I reboot all seems to go well: I get the black Windows XP screen with the progress bar, followed by the blue 'Welcome' screen and then.... that's as far as I get. I remain stuck at the blue screen with a Windows XP logo.

Please help, this is getting frustrating.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 29, 2006 4:28 pm 
Hero Member
Hero Member
User avatar

Joined: Mon Sep 05, 2005 1:56 am
Posts: 1440
By 'boot disk', I'm assuming you simply mean the harddrive with the OS on it? You mirrored that onto a SATA drive, from a regular ol' EIDE?

1. Can you boot into Safe Mode?

2. I recall that during installation of XP, you need to load SATA drivers at some point in the process. Perhaps, you need sata drivers installed? Maybe you can do this through safe mode?

3. XP is attempting to load the old hardware profile, expecting an IDE drive?

4. I'm totally guessing at all of this !aaah


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 29, 2006 9:04 pm 
Hero Member
Hero Member
User avatar

Joined: Mon Sep 05, 2005 1:59 pm
Posts: 1486
you need to run sysprep or risprep if it will be installed on new hardware, if it's HDD only then your fine.

Go safe mode delete all HDD from device manager and reboot!!!

_________________
Image


Top
 Profile  
 
 Post subject:
PostPosted: Fri Dec 29, 2006 9:05 pm 
Hero Member
Hero Member
User avatar

Joined: Mon Sep 05, 2005 1:59 pm
Posts: 1486
Oh and since you went from PATA to SATA you need to delete the IDE controllers as well and update your drivers and everything. IDE and SATA are not the same interface/INTERUPT

_________________
Image


Top
 Profile  
 
 Post subject:
PostPosted: Sat Dec 30, 2006 1:07 am 
Sr. Member
Sr. Member
User avatar

Joined: Mon Sep 05, 2005 1:32 am
Posts: 352
Hi guys, thanks for the replies.

All of the hardware was the same, the only change was the hard disk. I tried Norton Ghost and Partition Magic from within Windows. Perhaps a fixboot or fixmbr from the repair console would have done the trick.

Anyway everything is OK now. I used Paragon Partition Manager off of the Hiren's Boot CD which runs in dos to perform the partition clone. It booted into XP on the first try upon completion.

Some things are still best left to DOS I guess. :)


Top
 Profile  
 
 Post subject:
PostPosted: Sat Dec 30, 2006 3:49 pm 
Hero Member
Hero Member
User avatar

Joined: Mon Sep 05, 2005 1:59 pm
Posts: 1486
Good to hear it, I would still make sure the right driver is showing in device manager for the HDD controller and the drive itself.

_________________
Image


Top
 Profile  
 
 Post subject:
PostPosted: Sat Dec 30, 2006 5:16 pm 
Sr. Member
Sr. Member
User avatar

Joined: Mon Sep 05, 2005 1:32 am
Posts: 352
Both show up correctly so I think its ok.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 7 posts ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
twilightBB Style by Daniel St. Jules of Gamexe.net